7-3 Summit (25分)
A summit (峰会) is a meeting of heads of state or government. Arranging the rest areas for the summit is not a simple job. The ideal arrangement of one area is to invite those heads so that everyone is a direct friend of everyone.
Now given a set of tentative arrangements, your job is to tell the organizers whether or not each area is all set.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 200), the number of heads in the summit, and M, the number of friendship relations. Then M lines follow, each gives a pair of indices of the heads who are friends to each other. The heads are indexed from 1 to N.
Then there is another positive integer K (≤ 100), and K lines of tentative arrangement of rest areas follow, each first gives a positive number L (≤ N), then followed by a sequence of L distinct indices of the heads. All the numbers in a line are separated by a space.
Output Specification:
For each of the K areas, print in a line your advice in the following format:
if in this area everyone is a direct friend of everyone, and no friend is missing (that is, no one else is a direct friend of everyone in this area), print Area X is OK..
if in this area everyone is a direct friend of everyone, yet there are some other heads who may also be invited without breaking the ideal arrangement, print Area X may invite more people, such as H. where H is the smallest index of the head who may be invited.
if in this area the arrangement is not an ideal one, then print Area X needs help. so the host can provide some special service to help the heads get to know each other.
Here X is the index of an area, starting from 1 to K.
Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
2 4 6
3 3 2 1
Sample Output:
Area 1 is OK.
Area 2 is OK.
Area 3 is OK.
Area 4 is OK.
Area 5 may invite more people, such as 3.
Area 6 needs help.
#include <iostream>
#include <cstdio>
#include <unordered_map>
#include <set>
using namespace std;
unordered_map <int, set <int> > pr;
int n, m;
const int N = 200 + 10;
int main()
{
scanf("%d%d", &n, &m);
for(int i = 0; i < m; i ++)
{
int x, y;
scanf("%d%d", &x, &y);
pr[x].insert(y);
pr[y].insert(x);
}
int K;
scanf("%d", &K);
for(int i = 1; i <= K; i ++)
{
int t;
scanf("%d", &t);
int q[N];
set <int> tmp;
for(int j = 0; j < t; j ++)
{
scanf("%d", &q[j]);
if(j == 0) tmp = pr[q[j]];
else if(tmp.count(q[j])) tmp.erase(q[j]);
}
int flag = 0;
for(int j = 0; j < t; j ++)
{
int k = j + 1;
while(k < t)
{
if(pr[q[j]].count(q[k])) k ++;
else
{
flag = 1;
break;
}
}
if(flag == 1) break;
}
if(flag == 1)
{
printf("Area %d needs help.\n", i);
continue;
}
for (int j = 1; j < t; j ++)
{
for(auto t : tmp)
if(pr[q[j]].count(t) == 0) tmp.erase(t);
}
if(tmp.size())
printf("Area %d may invite more people, such as %d.\n", i, *(tmp.begin()));
else printf("Area %d is OK.\n", i);
}
return 0;
}