传送锚点:https://www.luogu.com.cn/problem/P1746
题目背景
《爱与愁的故事第三弹·shopping》最终章。
题目描述
爱与愁大神买完东西后,打算坐车离开中山路。现在爱与愁大神在 $x_1,y_1$ 处,车站在 $x_2,y_2$ 处。现在给出一个 $n \times n(n \le 1000)$ 的地图,$0$ 表示马路,$1$ 表示店铺(不能从店铺穿过),爱与愁大神只能垂直或水平着在马路上行进。爱与愁大神为了节省时间,他要求最短到达目的地距离(每两个相邻坐标间距离为 $1$)。你能帮他解决吗?
输入格式
第 $1$ 行包含一个数 $n$。
第 $2$ 行到第 $n+1$ 行:整个地图描述($0$ 表示马路,$1$ 表示店铺,注意两个数之间没有空格)。
第 $n+2$ 行:四个数 $x_1,y_1,x_2,y_2$。
输出格式
只有 $1$ 行,即最短到达目的地距离。
样例 #1
样例输入 #1
3
001
101
100
1 1 3 3
样例输出 #1
4
提示
对于 $20\%$ 数据,满足 $1\leq n \le 100$。
对于 $100\%$ 数据,满足 $1\leq n \le 1000$。
思路
code
#include<iostream>
#include<vector>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
int n;
const int maxn = 1e3 + 10;
char g[maxn][maxn];
int dist[maxn][maxn];
int x1, y1, x2, y2;
int dx[4] = { 1,0,0,-1 };
int dy[4] = { 0,1,-1,0 };
typedef pair<int, int> PII;
queue<PII> q;
void bfs(int x,int y) {//x、y为当前遍历点坐标
q.push({x,y});
while (!q.empty()){
auto t = q.front();
q.pop();
for (int i = 0; i < 4; i++) {
int nx = t.first + dx[i];
int ny = t.second + dy[i];
if (nx<0 || nx>=n || ny<0 || ny>=n) continue;
if (dist[nx][ny] != -1) continue;//dist不等于-1,代表走过这
if (g[nx][ny] == '1') continue;//店铺
q.push({nx,ny});
dist[nx][ny] = dist[t.first][t.second] + 1;
}
}
}
int main()
{
cin >> n;
memset(dist, -1, sizeof(dist));
for (int i = 0; i < n; i++) {
scanf("%s", g[i]);
}
cin >> x1 >> y1 >> x2 >> y2;
dist[x1 - 1][y1 - 1] = 0;//将x1和y1起始坐标标记为0
bfs(x1 - 1, y1 - 1);
cout << dist[x2 - 1][y2 - 1];
return 0;
}