【题目描述】
输出顺序表中的最大值
【输入形式】
元素个数
顺序表元素
【输出形式】
最大值
【输入样例】
5
2 8 4 9 7
【输出样例】
9
#include<iostream>
using namespace std;
#define OK 1
#define ERROR 0
#define OVERFLOW -2
#define MAXSIZE 100
typedef int Status;
typedef int ElemType;
typedef struct
{
ElemType* elem;
int length;
}SqList;
Status InitList(SqList& L)
{
L.elem = new ElemType[MAXSIZE];
L.length = 0;
return OK;
}
int main()
{
int n;
cin >> n;
SqList L;
InitList(L);
L.length = n;
int max = L.elem[1];
for (int i = 1; i <= n; i++)
{
cin >> L.elem[i];
if (L.elem[i] > max)
max = L.elem[i];
}
cout << max << endl;
return 0;
}