算法思路
共分两步:
- 把所有边按边权大小升序排序
- 遍历每一条边,如果这两条边不在同一个集合里,就将其合并到同一个集合中。
裸题
给定一个 n 个点 m 条边的无向图,图中可能存在重边和自环,边权可能为负数。
求最小生成树的树边权重之和,如果最小生成树不存在则输出 impossible
。
给定一张边带权的无向图 G=(V,E),其中 V 表示图中点的集合,E 表示图中边的集合,n=|V|,m=|E|。
由 V 中的全部 n 个顶点和 E 中 n−1 条边构成的无向连通子图被称为 G 的一棵生成树,其中边的权值之和最小的生成树被称为无向图 G 的最小生成树。
输入格式
第一行包含两个整数 n 和 m。
接下来 m 行,每行包含三个整数 u,v,w,表示点 u 和点 v 之间存在一条权值为 w 的边。
输出格式
共一行,若存在最小生成树,则输出一个整数,表示最小生成树的树边权重之和,如果最小生成树不存在则输出 impossible
。
数据范围
1≤n≤105,
1≤m≤2∗105,
图中涉及边的边权的绝对值均不超过 1000。
输入样例:
4 5
1 2 1
1 3 2
1 4 3
2 3 2
3 4 4
输出样例:
6
代码
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
const int N = 2e5 + 10;
using namespace std;
typedef pair<int, int> PII;
vector<pair<int, PII>> edges;
int n, m, res, cnt;
int p[N];
int find(int x) {
if (p[x] != x) p[x] = find(p[x]);
return p[x];
}
void kruskal() {
sort(edges.begin(), edges.end());
for (int i = 0; i < edges.size(); i ++) {
int a = find(edges[i].second.first);
int b = find(edges[i].second.second);
int w = edges[i].first;
if (a != b) {
res += w;
cnt ++;
p[a] = b;
}
}
return;
}
int main() {
cin >> n >> m;
for (int i = 1; i <= n; i ++) p[i] = i;
for (int i = 0; i < m; i ++) {
int a, b, w;
cin >> a >> b >> w;
edges.push_back({w, {a, b}});
}
kruskal();
if (cnt < n - 1) cout << "impossible" << endl;
else cout << res << endl;
return 0;
}
cnt
的作用:存储生成树中边的数量,一棵完整的最小生成树应该有 n−1 条边,否则则不存在。