1006 Sign In and Sign Out(25)
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS
, and ID_number
is a string with no more than 15 characters.
Output Specification
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output
SC3021234 CS301133
思路1
- 将时间转化为秒数,记录最小的时间和对应的id,记录最大的时间和对应的id
- 遍历所有记录边读入边更新即可
代码1
#include <cstdio>
#include <cstring>
typedef struct Student
{
char id[20];
int start, end;
} Student;
const int maxn = 10010;
Student ss[maxn];
int main()
{
int n;
scanf("%d", &n);
for (int i = 0; i < n; i++)
{
int h1, m1, s1, h2, m2, s2;
scanf("%s %d:%d:%d %d:%d:%d", ss[i].id, &h1, &m1, &s1, &h2, &m2, &s2);
ss[i].start = h1 * 60 * 60 + m1 * 60 + s1;
ss[i].end = h2 * 60 * 60 + m2 * 60 + s2;
}
int minTime = 24 * 60 * 60;
int maxTime = 0;
int maxid, minid;
for (int i = 0; i < n; i++)
{
if (ss[i].start < minTime)
{
minid = i;
minTime = ss[i].start;
}
if (ss[i].end > maxTime)
{
maxid = i;
maxTime = ss[i].end;
}
}
printf("%s %s\n", ss[minid].id, ss[maxid].id);
return 0;
}
#include <iostream>
using namespace std;
string min_s, max_s;
int min_t = 24 * 60 * 60, max_t = -1;
int main()
{
int m;
scanf("%d", &m);
string s;
int a, b, c;
while (m--)
{
cin >> s;
scanf("%d:%d:%d", &a, &b, &c);
int t = a * 60 * 60 + b * 60 + c;
if (t < min_t)
{
min_t = t;
min_s = s;
}
scanf("%d:%d:%d", &a, &b, &c);
t = a * 60 * 60 + b * 60 + c;
if (t > max_t)
{
max_t = t;
max_s = s;
}
}
cout << min_s << " " << max_s << endl;
return 0;
}
思路2
- 直接利用字符串的比较即可。字典序和真实值的顺序相同(位数是一样的,使用字典序即可),
string
自带一个比较函数 - 记录最小的时间和对应的id,记录最大的时间和对应的id
- 每次比较更新即可
- 第一个人直接赋值
比如数值 8<12 字典序 8>12
代码2
#include<bits/stdc++.h>
using namespace std;
int main()
{
string open_id, open_ti;
string close_id, close_ti;
int m;
cin >> m;
for(int i=0; i<m; i++)
{
string id, in_ti, out_ti;
cin >> id >> in_ti >> out_ti;
if(!i || in_ti < open_ti)
{
open_id = id;
open_ti = in_ti;
}
if(!i || out_ti > close_ti)
{
close_id = id;
close_ti = out_ti;
}
}
cout << open_id << " " << close_id << endl;
return 0;
}