1036 Boys vs Girls (25) 字符串处理
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.
Input Specification
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.
Output Specification
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade
F
−grade
M
. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.
Sample Input 1
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1
Mary EE990830
Joe Math990112
6
Sample Input 2
1
Jean M AA980920 60
Sample Output 2
Absent
Jean AA980920
NA
思路1
- 逐个处理输入,记录下女生分数最高和男生分数最低的
- 按要求输出即可
代码1
#include <iostream>
#include <string>
using namespace std;
string girl_first, boy_last;
int MAX = -1, MIN = 101, n;
int main()
{
cin >> n;
while (n--)
{
string name, sex, id;
int grade;
cin >> name >> sex >> id >> grade;
if (sex == "F" && grade > MAX)
{
girl_first = name + " " + id;
MAX = grade;
}
if (sex == "M" && grade < MIN)
{
boy_last = name + " " + id;
MIN = grade;
}
}
bool absent = false;
if (girl_first.size() == 0)
{
cout << "Absent" << endl;
absent = true;
}
else
cout << girl_first << endl;
if (boy_last.size() == 0)
{
cout << "Absent" << endl;
absent = true;
}
else
cout << boy_last << endl;
if (absent)
cout << "NA" << endl;
else
cout << MAX - MIN << endl;
return 0;
}
看来,我要系统学英语了。这让一个小学生很为难啊~!