PAT A1009 Product of Polynomials(25)[多项式相乘]
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
$K \quad N_1 a_{N_1} a_{N_2} … a_{N_K}$
where K is the number of nonzero terms in the polynomial, $N_i$ and $a_{N_i}$ ($i=1,2,⋯,K$) are the exponents and coefficients, respectively. It is given that $1 \leq K \leq 0,0 \leq N_K \cdots \leq N_2 \leq N_1 \leq 1000$.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
题意
两个多项式相乘,输出结果的项数,系数与指数
思路1
- 使用两个数组分别存储每个多项式项的系数
- 两重循环遍历所有情况,多项式
A
中的一项与多项式B
中的一项 $a_ix^n$ $b_jx^m$ 的乘积为 $a_ib_jx^{n+m}$
时间复杂度为 $O(N^2)$
代码1
#include <iostream>
using namespace std;
const int N = 1010;
double a[N], b[N], c[N * 2]; // double 数组
int main()
{
int k, x;
double y;
cin >> k;
for(int i = 0; i < k; i++)
{
cin >> x >> y;
a[x] = y;
}
cin >> k;
for(int i = 0; i < k; i++)
{
cin >> x >> y;
b[x] = y;
}
for(int i = 0; i < N; i++)
{
for(int j = 0; j < N; j++)
{
c[i + j] += a[i] * b[j];
}
}
int cnt = 0;
for(int i = 0; i < 2 * N; i++)
if(c[i])
cnt++;
cout << cnt;
for(int i = 2 * N - 1; i >= 0; i--)
{
if(c[i])
// cout << " " << i << " " << c[i];
printf(" %d %.1f", i, c[i]);
}
return 0;
}