PAT A1022 Digital Library(30)[数字图书馆,排序]
A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
- Line #1: the 7-digit ID number;
- Line #2: the book title – a string of no more than 80 characters;
- Line #3: the author – a string of no more than 80 characters;
- Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
- Line #5: the publisher – a string of no more than 80 characters;
- Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:
- 1: a book title
- 2: name of an author
- 3: a key word
- 4: name of a publisher
- 5: a 4-digit number representing the year
Output Specification:
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found
instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
题意
每本书有 ID
书名
作者
关键词
出版商
出版年限
等属性,对于每一个输入后关于五个属性的查询,输出所有属性为其的书的 ID
思路1
- 针对每一种属性建立一个属性到
ID
的映射 (id
自动升序排序) - 对于每一个查询,先在
map
中查找看是否存在,若存在,输出set
中的所有ID
代码1
#include <iostream>
#include <map>
#include <string>
#include <set>
using namespace std;
map<string, set<int>> book, author, key, publish, year; // 查询内容 -> 书籍id
void query(map<string, set<int>> &v, string &s)
{
if(v.find(s) != v.end())
{
for(auto &item : v[s])
printf("%07d\n", item);
}
else
{
printf("Not Found\n");
}
}
int main()
{
int n, id;
scanf("%d", &n);
string str, skey;
while(n--)
{
scanf("%d", &id);
getchar();
getline(cin, str);
book[str].insert(id);
getline(cin, str);
author[str].insert(id);
while(cin >> skey)
{
key[skey].insert(id);
char c = getchar();
if(c == '\n') break;
}
getline(cin, str);
publish[str].insert(id);
getline(cin, str);
year[str].insert(id);
}
int m, idx;
scanf("%d", &m);
string q;
while(m--)
{
scanf("%d: ", &idx);
printf("%d: ", idx);
getline(cin, q);
cout << q << endl;
if(idx == 1) query(book, q);
else if(idx == 2) query(author, q);
else if(idx == 3) query(key, q);
else if(idx == 4) query(publish, q);
else query(year, q);
}
return 0;
}