PAT A1052 Linked List Sorting(25)[链表排序,排序,链表]
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key
and a Next
pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Key Next
where Address
is the address of the node in memory, Key
is an integer in [−105,105], and Next
is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.
Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.
Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1
题意
找出链表中所有点,根据 key
排序,输出排序之后的链表,关键是排序之后地址的改变。
思路1
- 使用一个结构体数组表示链表,遍历一遍找出链表中节点个数,并将标志位置为
true
排序时链表中的节点就会排在前面。 - 根据前一个结点的
next
是后一个结点的开始地址address
控制输出 - 最后地址需要特判输出
-1
,中间地址5
位补零
代码1
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 1e5 + 10;
struct node
{
int address, key, next;
bool flag; // 是否在链表中
bool operator< (const node &n) const
{
if(flag != n.flag)
return flag > n.flag;
else
return key < n.key;
}
}Node[N];
int main()
{
int n, head, cnt = 0;
scanf("%d%d", &n, &head);
for(int i = 0; i < n; i++)
{
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
Node[a] = {a, b, c, false};
}
for(int i = head; i != -1; i = Node[i].next)
{
Node[i].flag = true;
cnt++;
}
if(cnt == 0)
{
printf("0 -1\n");
}
else
{
sort(Node, Node + N);
printf("%d %05d\n", cnt, Node[0].address);
for(int i = 0; i < cnt - 1; i++)
{
printf("%05d %d %05d\n", Node[i].address, Node[i].key, Node[i+1].address);
}
printf("%05d %d %d\n", Node[cnt - 1].address, Node[cnt - 1].key, -1);
}
return 0;
}