PAT A1004 Counting Leaves(30)[数叶子结点,树]
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
‘s of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
题意
找出树中每一层叶子结点数
思路1DFS
- 遍历到叶子结点将对应深度处的数量加1,同时更新最大深度以便于最后的输出
- 此处采用邻接表存储图,
v[i].size() == 0
表示无孩子即为叶节点,否则从上到下遍历所有的孩子节点,传入的深度depth+1
代码1
#include <iostream>
#include <vector>
using namespace std;
const int N = 110;
vector<int> v[N]; // 存储图
int d[N]; // 深度叶子个数
int maxdepth;
void dfs(int u, int depth)
{
if(!v[u].size()) // 叶子结点
{
d[depth]++;
maxdepth = max(maxdepth, depth);
return;
}
for(int i = 0; i < v[u].size(); i++)
dfs(v[u][i], depth+1);
}
int main()
{
int n, m;
scanf("%d%d", &n, &m);
while(m--)
{
int id, k, ch;
scanf("%d%d", &id, &k);
while(k--)
{
scanf("%d", &ch);
v[id].push_back(ch);
}
}
dfs(1, 0);
printf("%d", d[0]);
for(int i = 1; i <= maxdepth; i++)
printf(" %d", d[i]);
puts("");
return 0;
}