PAT A1043 Is It a Binary Search Tree(25)[判断二叉搜索树,树]
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node’s key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
- Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line YES
if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO
if not. Then if the answer is YES
, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
思路1
二叉搜索树的中序遍历是一个递增的序列,根据输入的前序遍历序列和排序之后的中序序列可以构造出一棵二叉树或者根据镜像(逆序之后的中序序列)可以构造出一棵二叉搜索树的话,则满足条件,输出后序遍历序列。
代码1
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 1010;
int n, cnt;
int preorder[N], inorder[N], postorder[N];
bool build(int il, int ir, int pl, int pr, int type)
{
if(il > ir) return true;
int root = preorder[pl];
int k;
if(type == 0)
{
// 找第一个
for(k = il; k <= ir; k++)
{
if(inorder[k] == root)
break;
}
if(k > ir) return false; // 无法构建
}
else
{
for(k = ir; k >= il; k--)
{
if(inorder[k] == root)
break;
}
if(k < il) return false;
}
bool ans = true;
if(!build(il, k - 1, pl + 1, pl + 1 + (k - 1 - il), type)) ans = false;
if(!build(k + 1, ir, pl + 1 + (k - 1 - il) + 1, pr, type)) ans = false;
postorder[cnt++] = root;
return ans;
}
int main()
{
cin >> n;
for(int i = 0; i < n; i++)
{
cin >> preorder[i];
inorder[i] = preorder[i];
}
sort(inorder, inorder + n);
if(build(0, n-1, 0, n-1, 0))
{
puts("YES");
cout << postorder[0];
for(int i = 1; i < n; i++)
cout << " " << postorder[i];
}
else
{
reverse(inorder, inorder + n);
cnt = 0;
if(build(0, n-1, 0, n-1, 1))
{
puts("YES");
cout << postorder[0];
for(int i = 1; i < n; i++)
cout << " " << postorder[i];
}
else
cout << "NO";
}
cout << endl;
return 0;
}
大佬,可以仔细讲讲是如何判断二叉搜索树的吗
https://www.acwing.com/solution/content/46226/
自以为写得清楚的题解/(ㄒoㄒ)/