PAT A1094 The Largest Generation(25)【最大的一代,DFS,BFS】
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a family member, K
(>0) is the number of his/her children, followed by a sequence of two-digit ID
‘s of his/her children. For the sake of simplicity, let us fix the root ID
to be 01
. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
题意
统计树节点最多的层数和节点数
思路1
-
使用
vector[N]
邻接表存储树 -
DFS
遍历到每一层将对应的计数器加1
代码1
#include <iostream>
#include <vector>
using namespace std;
const int N = 110;
vector<int> v[N]; // 孩子节点
int cnt[N]; // 每一层数量
void dfs(int u, int depth)
{
cnt[depth]++;
for(int i = 0; i < v[u].size(); i++)
{
dfs(v[u][i], depth + 1);
}
}
int main()
{
int n, m;
scanf("%d%d", &n, &m);
for(int i = 0; i < m; i++)
{
int id, k;
scanf("%d%d", &id, &k);
for(int j = 0; j < k; j++)
{
int son;
scanf("%d", &son);
v[id].push_back(son);
}
}
dfs(1, 1); // 根结点序号为1,第一层
int max_v = -1, max_idx = -1;
for(int i = 1; i < N; i++)
{
if(cnt[i] > max_v)
{
max_v = cnt[i];
max_idx = i;
}
}
printf("%d %d\n", max_v, max_idx);
return 0;
}
大佬,清楚明了啊,tql