PAT A1126 Eulerian Path(25)【欧拉回路,图,模拟】
In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian
, Semi-Eulerian
, or Non-Eulerian
. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian
题意
思路1
欧拉图
- 连通
- 所有顶点度为偶数
半欧拉图
- 连通
- 顶点的度两个奇数,其余为偶数
否则为非欧拉图
读入边时记录每个点的度数
判断连通性:图的遍历,看能否搜到所有顶点
代码1
#include <iostream>
using namespace std;
const int N = 510;
int n, m; // 点数,边数
bool g[N][N]; // 图
int d[N]; // 度
bool vis[N]; // 访问标记
int cnt = 0; // 连通块中的点数
void dfs(int u)
{
vis[u] = true;
cnt++;
for(int i = 1; i <= n; i++)
if(!vis[i] && g[u][i] == true)
dfs(i);
}
int main()
{
scanf("%d%d", &n, &m);
for(int i = 0; i < m; i++)
{
int a, b;
scanf("%d%d", &a, &b);
g[a][b] = g[b][a] = true;
d[a]++, d[b]++;
}
dfs(1);
int t = 0;
for(int i = 1; i <= n; i++)
{
printf("%d%c", d[i], (i == n) ? '\n' : ' ');
if(d[i] % 2 != 0)
t++;
}
// 连通
if(cnt == n)
{
if(t == 0)
printf("Eulerian\n");
else if(t == 2)
printf("Semi-Eulerian\n");
else
printf("Non-Eulerian");
}
else // 非连通
printf("Non-Eulerian\n");
return 0;
}
请问检查图的连通性时需要恢复现场吗
这里的dfs(1)的作用,,是什么