PAT A1154 Vertex Coloring(25)【顶点着色,图,模拟】
A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) *k*-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line k-coloring
if it is a proper k
-coloring for some positive k
, or No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No
题意
思路1
- 依次判断每一条边的两个顶点颜色是否相同
- 使用一个哈希表记录颜色总数
代码1
#include <iostream>
#include <unordered_set>
using namespace std;
const int N = 1e4+10;
int n, m, k, cnt;
struct Edge
{
int a, b;
}edge[N];
int v[N];
unordered_set<int> s;
int main()
{
scanf("%d%d", &n, &m);
for(int i = 0; i < m; i++)
scanf("%d%d", &edge[i].a, &edge[i].b);
scanf("%d", &cnt);
while(cnt--)
{
s.clear(); // 清空哈希表
for(int i = 0; i < n; i++)
{
scanf("%d", &v[i]);
if(s.count(v[i]) == 0)
s.insert(v[i]);
}
bool flag = true;
for(int i = 0; i < m; i++)
{
if(v[edge[i].a] == v[edge[i].b])
{
flag = false;
break;
}
}
if(flag)
printf("%d-coloring\n", s.size());
else
puts("No");
}
return 0;
}
PAT A1154 Vertex Coloring(25)【顶点着色,图,模拟】
A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) *k*-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line k-coloring
if it is a proper k
-coloring for some positive k
, or No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No
题意
思路1
- 依次判断每一条边的两个顶点颜色是否相同
- 使用一个哈希表记录颜色总数
代码1
#include <iostream>
#include <unordered_set>
using namespace std;
const int N = 1e4+10;
int n, m, k, cnt;
struct Edge
{
int a, b;
}edge[N];
int v[N];
unordered_set<int> s;
int main()
{
scanf("%d%d", &n, &m);
for(int i = 0; i < m; i++)
scanf("%d%d", &edge[i].a, &edge[i].b);
scanf("%d", &cnt);
while(cnt--)
{
s.clear(); // 清空哈希表
for(int i = 0; i < n; i++)
{
scanf("%d", &v[i]);
if(s.count(v[i]) == 0)
s.insert(v[i]);
}
bool flag = true;
for(int i = 0; i < m; i++)
{
if(v[edge[i].a] == v[edge[i].b])
{
flag = false;
break;
}
}
if(flag)
printf("%d-coloring\n", s.size());
else
puts("No");
}
return 0;
}