PAT A1134 Vertex Cover(25)【顶点着色,图,哈希】
A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:
Nv v[1] v[2]⋯v[Nv]
where Nv is the number of vertices in the set, and v[i]’s are the indices of the vertices.
Output Specification:
For each query, print in a line Yes
if the set is a vertex cover, or No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
题意
如果图中的一个顶点集合能够满足图中的每一条边都至少有一个端点在该集合内,那么这个顶点集合就是图的顶点覆盖。
现在给定一张图,以及若干个顶点集合,请你判断这些顶点集合是否是图的顶点覆盖。
思路1
- 使用一个结构体数组记录下所有的边
- 每次处理集合的时候记录下集合中的所有顶点(哈希)
- 遍历所有的边看是否存在一条边的两个顶点在集合中都不出现,是则为No,否则为Yes
代码1
#include <iostream>
#include <unordered_set>
using namespace std;
const int N = 1e4 + 10;
int n, m;
struct Edge
{
int a, b;
}e[N];
unordered_set<int> s;
int main()
{
scanf("%d%d", &n, &m);
for(int i = 0; i < m; i++)
scanf("%d%d", &e[i].a, &e[i].b);
int k;
scanf("%d", &k);
while(k--)
{
s.clear();
int cnt;
scanf("%d", &cnt);
for(int i = 0; i < cnt; i++)
{
int a;
scanf("%d", &a);
s.insert(a);
}
bool valid = true;
for(int i = 0; i < m; i++)
{
if(s.count(e[i].a) == 0 && s.count(e[i].b) == 0)
{
valid = false;
break;
}
}
printf("%s\n", valid ? "Yes" : "No");
}
return 0;
}