题目描述
输入一行字符,长度不超过100,请你统计一下其中的数字字符的个数。
输入格式
输入一行字符。注意其中可能包含空格。
输出格式
输出一个整数,表示字数字字符的个数。
样例
输入样例:
I am 18 years old this year.
输出样例:
2
算法
0在ASCII中为48,9为57.
C++ 代码(蒟蒻编写)
#include<bits/stdc++.h>
using namespace std;
int main (){
string s;
getline(cin,s);
int cnt=0;
for(int i=0;i<s.size();i++)
if(s[i]>=48&&s[i]<=57)cnt++;
cout<<cnt;
return 0;
}