PAT A1019 General Palindromic Number(20)【普通回文数,进位制】
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as ∑i=0k(aibi). Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes
if N is a palindromic number in base b, or No
if not. Then in the next line, print N as the number in base b in the form “ak ak−1 … a0”. Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
题意
- 判断一个正整数
n
在b
进制下是否是回文数
思路1
- 将正整数
n
转化为b
进制 - 判断是否回文,需要注意
0
的特判
代码1
#include <iostream>
using namespace std;
const int N = 20;
int a[N], n, b, idx;
int main()
{
scanf("%d%d", &n, &b);
while(n)
{
a[idx++] = n % b;
n /= b;
}
bool ans = true;
for(int i = 0; i <= idx/2; i++)
if(a[i] != a[idx - 1 - i])
{
ans = false;
break;
}
printf("%s\n", ans ? "Yes" : "No");
// 0的时候特判
if(idx == 0)
printf("0\n");
for(int i = idx - 1; i >= 0; i--)
printf("%d%c", a[i], (i == 0) ? '\n' : ' ');
return 0;
}
这份代码过不了pat啊兄弟, y总的是可以过的
y总的在哪看,找不到哈