题目描述
假定有一个无限长的数轴,数轴上每个坐标上的数都是0。
现在,我们首先进行 n 次操作,每次操作将某一位置x上的数加c。
接下来,进行 m 次询问,每个询问包含两个整数l和r,你需要求出在区间[l, r]之间的所有数的和。
输入格式
第一行包含两个整数n和m。
接下来 n 行,每行包含两个整数x和c。
再接下里 m 行,每行包含两个整数l和r。
输出格式
共m行,每行输出一个询问中所求的区间内数字和。
数据范围
−109≤x≤109,
1≤n,m≤105,
−109≤l≤r≤109,
−10000≤c≤10000
样例
输入样例:
3 3
1 2
3 6
7 5
1 3
4 6
7 8
输出样例:
8
0
5
算法1
一发链接:
离散化详解
C++ 代码
#include<bits/stdc++.h>
using namespace std;
const int N = 300010;
int n,m,a[N],s[N];
vector<int> alls;
vector<pair<int, int>> add, query;
int find(int x)
{
int l = 0, r = alls.size() - 1;
while(l < r)
{
int mid = (l + r)>> 1;
if(alls[mid] >= x) r = mid;
else l = mid + 1;
}
return r + 1;
}
int main()
{
cin >> n >> m;
for(int i = 0; i < n; i ++)
{
int x,c;
cin>>x>>c;
alls.push_back(x);
add.push_back({x, c});
}
for(int i = 0; i < m; i ++)
{
int l,r;
cin>>l>>r;
alls.push_back(l);
alls.push_back(r);
query.push_back({l, r});
}
sort(alls.begin(), alls.end());
alls.erase(unique(alls.begin(), alls.end()), alls.end());
for(auto i : add)
{
int x = find(i.first);
a[x] += i.second;
}
for(int i = 1; i <= alls.size(); i ++) s[i] = s[i - 1] + a[i];
for(auto i : query)
{
int l = find(i.first), r = find(i.second);
cout << s[r] - s[l - 1] << endl;
}
}