题目描述
在一条数轴上有 N 家商店,它们的坐标分别为 A1~AN。
现在需要在数轴上建立一家货仓,每天清晨,从货仓到每家商店都要运送一车商品。
为了提高效率,求把货仓建在何处,可以使得货仓到每家商店的距离之和最小。
样例
输入样例:
4
6 2 9 1
输出样例:
12
算法
(绝对值不等式)
时间复杂度
$O(n)$
C++ 代码
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 100010;
int n;
int a[N];
int main()
{
cin >> n;
for(int i = 0; i < n; i ++) cin >> a[i];
sort(a, a + n);
int md = a[n / 2];
int res = 0;
for(int i = 0; i < n; i ++) res += abs(a[i] - md);
cout << res << endl;
return 0;
}