Descriptions
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0, m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
Output
每一组输入数据对应一行输出。如果能消去则输出”YES”,不能则输出”NO”。
Sample Input
3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0
Sample Output
YES
NO
NO
NO
NO
YES
题解
①搜索dfs(x,y,dic,turns)
- x,y为当前搜索起点
- dir为当前前进方向
- turns为当前转弯数
②注意初始化及边界情况
③注意搜索终止条件
剪枝:第二次转弯后,判断与目标是否在同一直线上
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<sstream>
#include<set>
#include<bitset>
#include<vector>
#include<cmath>
using namespace std;
int dx[]={-1,0,1,0,0},dy[]={0,1,0,-1,0};
typedef pair<int,int> PII;
typedef long long LL;
const int INF=0x3f3f3f3f;
const int N=1010;
int g[N][N];
bool vis[N][N];
int n,m,q;
int x1,y1,x2,y2;
inline check(int a,int b)
{
if(a>=1 && a<=n && b>=1 && b<=m)
if(!g[a][b] || (a==x2 && b==y2)) return true;
return false;
}
bool dfs(int x,int y,int dir,int turns)
{
//cout<<"---"<<x<<' '<<y<<' '<<turns<<endl;
if(turns > 2) return false;
if(turns == 2)
{
if(abs(x-x2) && abs(y-y2)) return false;
}
if(x == x2 && y == y2) return true;
for(int i=0;i<4;i++)
{
int a=x+dx[i],b=y+dy[i];
if(check(a,b))
{
if(dir == i || dir == -1)
{
if(dfs(a,b,i,turns)) return true;
}
else
{
if(dfs(a,b,i,turns+1)) return true;
}
}
}
return false;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(!n && !m) break;
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
scanf("%d",&g[i][j]);
cin>>q;
while(q--)
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
if(g[x1][y1] && g[x1][y1] == g[x2][y2])
{
if(dfs(x1,y1,-1,0)) puts("YES");
else puts("NO");
}
else puts("NO");
}
}
//system("pause");
}