1004 Counting Leaves (30分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
#include<bits/stdc++.h>
using namespace std;
const int N=110;
vector<int> v[N]; //邻接表存储图
int cnt[N]; //每一深度(层)叶子点数
int maxdepth; //最大深度(层)便于最后输出
void dfs(int u,int depth)
{
if(!v[u].size()) //没有边,表示叶子结点
{
cnt[depth]++;
maxdepth=max(maxdepth,depth);
return;
}
for(int i=0;i<v[u].size();i++)
dfs(v[u][i],depth+1);
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
while(m--)
{
int id,childnum,child;
scanf("%d%d",&id,&childnum);
while(childnum--)
{
scanf("%d",&child);
v[id].push_back(child);
}
}
dfs(1,0);
printf("%d",cnt[0]);
for(int i=1;i<=maxdepth;i++)
printf(" %d",cnt[i]);
printf("\n");
return 0;
}
IEE
???
老铁,这个题解是不是放错位置了