1127 ZigZagging on a Tree (30分)
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
zigzag.jpg
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
#include<bits/stdc++.h>
using namespace std;
const int N=40;
int n;
unordered_map<int,int> l,r,pos;
int in[N],post[N];
vector<int> res;
int build(int il, int ir, int pl, int pr)
{
int root = post[pr];
int k = pos[root];
if (il < k) l[root] = build(il, k - 1, pl, pl + k - 1 - il);
if (k < ir) r[root] = build(k + 1, ir, pl + k - 1 - il + 1, pr - 1);
return root;
}
void bfs(int root)
{
queue<int> q;
q.push(root);
bool flag=0;
while(!q.empty())
{
int size=q.size();
for(int j=0;j<size;j++) //一层一层做bfs
{
auto i=q.front();
q.pop();
res.push_back(i);
if(l[i]!=0) q.push(l[i]);
if(r[i]!=0) q.push(r[i]);
}
flag=!flag;
if(flag) reverse(res.begin()+res.size()-size,res.end()); //Z字形 这里做文章,一层反转一层不反转
}
}
int main()
{
cin>>n;
for(int i=0;i<n;i++)
{
cin>>in[i];
pos[in[i]]=i;
}
for(int i=0;i<n;i++) cin>>post[i];
int root=build(0,n-1,0,n-1);
bfs(root);
cout<<res[0];
for(int i=1;i<res.size();i++)
cout<<' '<<res[i];
cout<<endl;
return 0;
}