1099 Build A Binary Search Tree (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
figBST.jpg
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
#include<bits/stdc++.h>
using namespace std;
const int N=110;
int n;
int l[N],r[N],v[N];
int inorder[N];
void dfs(int u,int &k) //整个dfs使用一个k,加引用,也可直接定义成全局变量
{
if(u==-1) return;
dfs(l[u],k);
v[u]=inorder[k++];
dfs(r[u],k);
}
void bfs(int root)
{
queue<int> q;
q.push(root);
bool flag=true;
while(!q.empty())
{
auto t=q.front();
q.pop();
if(flag)
{
cout<<v[t];
flag=0;
}
else cout<<' '<<v[t];
if(l[t]!=-1) q.push(l[t]);
if(r[t]!=-1) q.push(r[t]);
}
}
int main()
{
memset(l,-1,sizeof l);
memset(r,-1,sizeof r);
cin>>n;
for(int i=0;i<n;i++)
{
int a,b;
cin>>a>>b;
l[i]=a,r[i]=b;
}
for(int i=0;i<n;i++)
cin>>inorder[i];
sort(inorder,inorder+n);
int k=0;
dfs(0,k);
bfs(0);
return 0;
}