1107 Social Clusters (30分)
When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] … hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int N=1010;
int n;
vector<int> hobby[N]; //每个爱好有哪些人
int p[N];
int cnt[N]; //统计每个社群多少人
int find(int x)
{
if(p[x]!=x) p[x]=find(p[x]);
return p[x];
}
int main()
{
cin>>n;
for(int i=1;i<=n;i++)
{
int cnt;
scanf("%d:",&cnt);
while(cnt--)
{
int h;
cin>>h;
hobby[h].push_back(i);
}
}
for(int i=1;i<=n;i++) p[i]=i;
for(int i=1;i<=1000;i++)
for(int j=1;j<hobby[i].size();j++)
{
int a=hobby[i][0],b=hobby[i][j];
p[find(a)]=find(b);
}
for(int i=1;i<=n;i++) cnt[find(i)]++;
sort(cnt,cnt+n+1,greater<int>()); //第一个不用,多加一个1
int k=0;
while(cnt[k]) k++;
cout<<k<<endl;
cout<<cnt[0];
for(int i=1;i<k;i++) cout<<' '<<cnt[i];
cout<<endl;
return 0;
}
帮助你提高英语水平,朋友,hhhh
呜呜呜,貌似又忘记加翻译了qwq