1018 Public Bike Management (30分)
There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.
The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.
When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:
PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.
PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,⋯,N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1−>⋯−>Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.
Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.
Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
/*
1:这一题,题意的理解十分关键,主要有两个点,在花费时间最少的前提下,一个是在去的路上进行调整,能够带的单车最少优先;如果还是有多条,那么带回单车最少的优先。说明只能在去的路上对车站的车进行调整,回的时候不能够进行调整,试想如果回的时候也可以调整,那么就不会出现第二个限制条件了。
2:使用Djikstra+DFS
3:同时在每个车站的车数量输入,进行减去(C+1)/2本题为偶数,其实不需要向上取整,直接对于操作,方便后续操作。具体参考代码处
4:对于每个车站多了两个属性,一个是send,一个是bring,sned记录到该车站处所欠缺的数量,也就是需要从管理中心调过来车的数量;bring记录到该车站处,多余的车,也就是往回运的车。
*/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int N=510,INF=0x3f3f3f3f;
int C,n,S,m;
int c[N];
int g[N][N];
int dist[N];
bool st[N];
vector<int> path,ans;
int send=INF,bring=INF;
void dijkstra()
{
memset(dist,0x3f,sizeof dist);
dist[S]=0;
for(int i=0;i<n;i++)
{
int t=-1;
for(int j=0;j<=n;j++)
if(!st[j]&&(t==-1||dist[j]<dist[t]))
t=j;
st[t]=true;
for(int j=0;j<=n;j++)
dist[j]=min(dist[j],dist[t]+g[t][j]);
}
}
void dfs(int u,int s,int mins)
{
if(u)
{
s-=(C+1)/2-c[u]; // 所有最小值是需要带的自行车,最后+send为需要带回来的自行车
mins=min(mins,s);
}
if(u==S)
{
int sd=abs(min(mins,0));
int bg=s+sd;
if(sd<send) ans=path,send=sd,bring=bg; //看需不需要更新路径
else if(sd==send&&bg<bring) ans=path,bring=bg;
return ;
}
for(int i=1;i<=n;i++)
if(dist[u]==g[u][i]+dist[i])
{
path.push_back(i);
dfs(i,s,mins);
path.pop_back(); //深搜完一条路径返回时恢复现场
}
}
int main()
{
cin>>C>>n>>S>>m;
for(int i=1;i<=n;i++) cin>>c[i];
memset(g,0x3f,sizeof g);
for(int i=0;i<m;i++)
{
int x,y,z;
cin>>x>>y>>z;
g[x][y]=g[y][x]=min(g[x][y],z);
}
dijkstra(); //先从反向求终点到其它点的最短路
path.push_back(0); //先把起点压进去
dfs(0,0,0); //当前从起点出发,最开始一辆自行车都不带,中间的最小值是0
cout<<send<<' '<<0;
for(int i=1;i<ans.size();i++)
cout<<"->"<<ans[i];
cout<<' '<<bring<<endl;
return 0;
}