题目描述
实现一个栈,栈初始为空,支持四种操作:
(1) “push x” – 向栈顶插入一个数x;
(2) “pop” – 从栈顶弹出一个数;
(3) “empty” – 判断栈是否为空;
(4) “query” – 查询栈顶元素。
现在要对栈进行M个操作,其中的每个操作3和操作4都要输出相应的结果。
输入样例
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty
输出样例:
5
5
YES
4
NO
C++ 代码
#include <iostream>
using namespace std;
const int N = 100010;
int st[N], tt=0;
int m;
//push压栈
void push(int x)
{
st[++tt] = x;
}
//pop出栈
void pop()
{
tt--;
}
//查询栈是否为空 empty
bool empty()
{
if(tt)
return false;
else
return true;
}
//查询栈顶元素, 类似于stl中的top函数
int query()
{
return st[tt];
}
int main()
{
cin >> m;
while(m--)
{
string op;
int x;
cin >> op;
if(op == "push")
{
cin >> x;
push(x);
}
else if(op == "pop")
{
pop();
}
else if(op == "empty")
{
cout << (empty() ? "YES" : "NO" ) <<endl;
}
else if(op == "query")
{
cout << query() << endl;
}
}
return 0;
}