习题8.4 畅通工程之最低成本建设问题 (30分)
某地区经过对城镇交通状况的调查,得到现有城镇间快速道路的统计数据,并提出“畅通工程”的目标:使整个地区任何两个城镇间都可以实现快速交通(但不一定有直接的快速道路相连,只要互相间接通过快速路可达即可)。现得到城镇道路统计表,表中列出了有可能建设成快速路的若干条道路的成本,求畅通工程需要的最低成本。
输入格式:
输入的第一行给出城镇数目N (1<N≤1000)和候选道路数目M≤3N;随后的M行,每行给出3个正整数,分别是该条道路直接连通的两个城镇的编号(从1编号到N)以及该道路改建的预算成本。
输出格式:
输出畅通工程需要的最低成本。如果输入数据不足以保证畅通,则输出“Impossible”。
输入样例1:
6 15
1 2 5
1 3 3
1 4 7
1 5 4
1 6 2
2 3 4
2 4 6
2 5 2
2 6 6
3 4 6
3 5 1
3 6 1
4 5 10
4 6 8
5 6 3
输出样例1:
12
输入样例2:
5 4
1 2 1
2 3 2
3 1 3
4 5 4
输出样例2:
Impossible
#include<iostream>
#include<cstring>
#include<unordered_set>
#include<algorithm>
using namespace std;
const int N=1010,M=3030;
int n,m;
struct edge
{
int v1,v2,cost,st=0;
}e[M];
bool cmp(edge a,edge b)
{
return a.cost<b.cost;
}
int p[N];
int find(int x)
{
if(p[x]!=x) p[x]=find(p[x]);
return p[x];
}
int main()
{
cin>>n>>m;
for(int i=1;i<=n;i++) p[i]=i;
for(int i=1;i<=m;i++)
{
cin>>e[i].v1>>e[i].v2>>e[i].cost;
}
sort(e,e+m,cmp);
int res=0,count=0;
for(int i=1;i<=m;i++)
{
int f1=find(e[i].v1),f2=find(e[i].v2);
if(f1!=f2)
{
p[f1]=f2;
res+=e[i].cost;
count++;
e[i].st=1;
}
}
if(count!=n-1) cout<<"Impossible"<<endl;
else
{
unordered_set<int> s;
for(int i=1;i<=m;i++)
if(e[i].st==1) s.insert(e[i].v1),s.insert(e[i].v2);
for(auto a:s) cout<<a<<' '; //自己加的,输入那几条边连在一起
cout<<endl;
cout<<res<<endl;
}
return 0;
}