题目描述
输入一个n行m列的整数矩阵,再输入q个操作,每个操作包含五个整数x1, y1, x2, y2, c,其中(x1, y1)和(x2, y2)表示一个子矩阵的左上角坐标和右下角坐标。
每个操作都要将选中的子矩阵中的每个元素的值加上c。
请你将进行完所有操作后的矩阵输出。
输入格式
第一行包含整数n,m,q。
接下来n行,每行包含m个整数,表示整数矩阵。
接下来q行,每行包含5个整数x1, y1, x2, y2, c,表示一个操作。
输出格式
共 n 行,每行 m 个整数,表示所有操作进行完毕后的最终矩阵。
数据范围
1≤n,m≤1000,
1≤q≤100000,
1≤x1≤x2≤n,
1≤y1≤y2≤m,
−1000≤c≤1000,
−1000≤矩阵内元素的值≤1000
输入样例:
3 4 3
1 2 2 1
3 2 2 1
1 1 1 1
1 1 2 2 1
1 3 2 3 2
3 1 3 4 1
输出样例:
2 3 4 1
4 3 4 1
2 2 2 2
算法1
思路
1.构造差分矩阵(假设原数组为0,先在每个区间(点)上+a[i][j]即2操作)
2.对原数组(x1,y1)(x2,y2)区间所有点+c相当于在差分矩阵如图操作
3.对差分矩阵求前缀和就是原数组
时间复杂度
构造差分矩阵是O(N),每一次操作是O(1)
Java 代码
import java.io.*;
public class Main {
private static int N = 1010;
private static int M = 1010;
private static int[][] a = new int[N][M];
private static int[][] b = new int[N][M];
public static void main(String[] args) throws Exception{
BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter writer = new BufferedWriter(new OutputStreamWriter(System.out));
//split不要拼错!!
String[] str = reader.readLine().split(" ");
int n = Integer.parseInt(str[0]);
int m = Integer.parseInt(str[1]);
int q = Integer.parseInt(str[2]);
for(int i = 1; i < n + 1; i++){
str = reader.readLine().split(" ");
for(int j = 1; j < m + 1; j++){
//这里str下标是j-1
a[i][j] = Integer.parseInt(str[j - 1]);
//构造差分矩阵b
insert(b,i,j,i,j,a[i][j]);
}
}
while(q-- > 0){
str = reader.readLine().split(" ");
int x1 = Integer.parseInt(str[0]);
int y1 = Integer.parseInt(str[1]);
int x2 = Integer.parseInt(str[2]);
int y2 = Integer.parseInt(str[3]);
int c = Integer.parseInt(str[4]);
insert(b,x1,y1,x2,y2,c);
}
for(int i = 1; i < n + 1; i++){
for(int j = 1; j < m + 1; j++){
//求矩阵前缀和
//这里写+=后面就不用+b[i][j]了,否则是双倍
b[i][j] = b[i - 1][j] + b[i][j - 1] - b[i - 1][j - 1] + b[i][j];
writer.write(b[i][j] + " ");
}
writer.write("\n");
}
writer.flush();
writer.close();
reader.close();
}
public static void insert(int[][] b, int x1, int y1, int x2, int y2, int c){
b[x1][y1] += c;
b[x1][y2 + 1] -= c;
b[x2 + 1][y1] -= c;
b[x2 + 1][y2 + 1] += c;
}
}
清晰明了 nb👍
终于来了一个看得懂的图了(以及图解,哭泣)