AcWing 1233. 全球变暖
原题链接
简单
作者:
凡森Zfans
,
2020-08-31 12:22:34
,
所有人可见
,
阅读 631
/*全球变暖
你有一张某海域NxN像素的照片,"."表示海洋、"#"表示陆地,如下所示:
.......
.##....
.##....
....##.
..####.
...###.
.......
其中"上下左右"四个方向上连在一起的一片陆地组成一座岛屿。例如上图就有2座岛屿。
由于全球变暖导致了海面上升,科学家预测未来几十年,岛屿边缘一个像素的范围会被海水淹没。具体来说如果一块陆地像素与海洋相邻(上下左右四个相邻像素中有海洋),它就会被淹没。
例如上图中的海域未来会变成如下样子:
.......
.......
.......
.......
....#..
.......
.......
请你计算:依照科学家的预测,照片中有多少岛屿会被完全淹没。
【输入格式】
第一行包含一个整数N。 (1 <= N <= 1000)
以下N行N列代表一张海域照片。
照片保证第1行、第1列、第N行、第N列的像素都是海洋。
【输出格式】
一个整数表示答案。
【输入样例】
7
.......
.##....
.##....
....##.
..####.
...###.
.......
【输出样例】
1
资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms
请严格按要求输出,不要画蛇添足地打印类似:“请您输入...” 的多余内容。
注意:
main函数需要返回0;
只使用ANSI C/ANSI C++ 标准;
不要调用依赖于编译环境或操作系统的特殊函数。
所有依赖的函数必须明确地在源文件中 #include <xxx>
不能通过工程设置而省略常用头文件。
提交程序时,注意选择所期望的语言类型和编译器类型。
*/
#include<bits/stdc++.h>
using namespace std;
char dt[1000][1000];
bool vis[1000][1000];
int n, ans;
struct point {
int x, y;
point(int xx, int yy) {
x = xx;
y = yy;
}
};
int dir[4][2] = {{-1, 0},
{1, 0},
{0, -1},
{0, 1}};
bool check(int r, int c) {
for (int i = 0; i < 4; ++i) {
int rr = r + dir[i][0];
int cc = c + dir[i][1];
if (dt[rr][cc] == '.') {
return true;
}
}
return false;
}
bool bfs(int r, int c) {
vis[r][c] = true;
queue <point> q;
q.push(point(r, c));
int cnt1 = 0, cnt2 = 0;
while (!q.empty()) {
cnt1++;
point p = q.front();
q.pop();
if (check(p.x, p.y)) {
cnt2++;
}
for (int i = 0; i < 4; ++i) {
int rr = p.x + dir[i][0];
int cc = p.y + dir[i][1];
if (dt[rr][cc] == '#' && !vis[rr][cc]) {
q.push(point(rr, cc));
vis[rr][cc] = true;
}
}
}
if (cnt1 == cnt2) {
return true;
}
return false;
}
int main() {
ios_base::sync_with_stdio(false);
cin.tie(NULL);
cout.tie(NULL);
cin >> n;
for (int i = 0; i < n; ++i) {
for (int j = 0; j < n; ++j) {
cin >> dt[i][j];
}
}
for (int i = 0; i < n; ++i) {
for (int j = 0; j < n; ++j) {
if (dt[i][j] == '#' && !vis[i][j]) {
if (bfs(i, j)) {
ans++;
}
}
}
}
cout << ans << '\n';
return 0;
}