题目描述
PAT 准考证号由 4 部分组成:
第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
第 2∼4 位是考场编号,范围从 101 到 999;
第 5∼10 位是考试日期,格式为年、月、日顺次各占 2 位;
最后 11∼13 位是考生编号,范围从 000 到 999。
现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。
输出格式
对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:
类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
类型 为 2 的指令,按 人数 总分 的格式输出;
类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。
如果查询结果为空,则输出 NA。
样例
输入样例:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
输出样例:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
算法
利用了vector和hash表来存储字符串,按照题目要求输出即可
C++ 代码
#include<bits/stdc++.h>
using namespace std;
const int N=10010;
struct person{
string id;
int score;
}p[N];
bool cmp(person a,person b)
{
if(a.score!=b.score)
return a.score>b.score;
else return a.id<b.id;
}
int main()
{
int m,n;
cin>>m>>n;
for(int i=0;i<m;i++)
cin>>p[i].id>>p[i].score;
for(int k=1;k<=n;k++)
{
string t,c;
cin>>t>>c;
printf("Case %d: %s %s\n",k,t.c_str(),c.c_str());
if(t=="1")
{
vector<person> pon;
for(int i=0;i<m;i++)
if(p[i].id[0]==c[0])
pon.push_back(p[i]);
sort(pon.begin(),pon.end(),cmp);
if(pon.empty()) cout<<"NA"<<endl;
else
for(auto p:pon)
printf("%s %d\n",p.id.c_str(),p.score);
}
else if(t=="2")
{
int sum=0,cnt=0;
for(int i=0;i<m;i++)
if(p[i].id.substr(1,3)==c)
{
cnt++;
sum+=p[i].score;
}
if(!cnt)cout<<"NA"<<endl;
else printf("%d %d\n",cnt,sum);
}
else{
unordered_map<string,int> hash;
for(int i=0;i<m;i++)
if(p[i].id.substr(4,6)==c)
hash[p[i].id.substr(1,3)]++;
//利用vector(pair)从hash表中取出第一个键考室号,以及第二个键该考室号的人数
vector<pair<int,string>> room;
for(auto t:hash)
room.push_back({-t.second,t.first}); //因为vecotr默认递增的,加符号使其变为递减,以此存入vector的第一个键(加负号即可),第二个键存入考室号
sort(room.begin(),room.end()); //使其递减排序
if(room.empty()) cout<<"NA"<<endl;
else
for(auto r:room)
printf("%s %d\n",r.second.c_str(),-r.first);
}
}
return 0;
}