题目描述
实现一个栈,栈初始为空,支持四种操作:
(1) “push x” – 向栈顶插入一个数x;
(2) “pop” – 从栈顶弹出一个数;
(3) “empty” – 判断栈是否为空;
(4) “quert” – 查询栈顶元素。
现在要对栈进行M个操作,其中的每个操作3和操作4都要输出相应的结果。
输入格式
第一行包含整数M,表示操作次数。
接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”quert”中的一种。
输出格式
对于每个”empty”和”quert”操作都要输出一个查询结果,每个结果占一行。
其中,”empty”操作的查询结果为“YES”或“NO”,”quert”操作的查询结果为一个整数,表示栈顶元素的值。
数据范围
1≤M≤100000,
1≤x≤109
所有操作保证合法。
样例
输入样例:
10
push 5
quert
push 6
pop
quert
pop
empty
push 4
quert
empty
输出样例:
5
5
YES
4
NO
算法1
投机取巧 使用了stl
学习的话 还是认真实现stack吧
C++ 代码
#include <stack>
#include <iostream>
using namespace std;
stack<int> st;
void DoCommand(const string& s,int m)
{
if(s == "push"){
st.push(m);
}else if(s == "quert"){
cout << st.top() << endl;
}else if(s == "pop"){
st.pop();
}else if(s == "empty"){
if(st.empty())
cout << "YES" << endl;
else
cout << "NO" << endl;
}
}
int main()
{
stack<int> st;
int n;
cin >> n;
for(int i =0;i < n;i++){
string s; int m;
cin >> s;
if(s == "push"){
cin >> m;
}
DoCommand(s,m);
}
return 0;
}