7-2 How Many Ways to Buy a Piece of Land
The land is for sale in CyberCity, and is divided into several pieces. Here it is assumed that each piece of land has exactly two neighboring pieces, except the first and the last that have only one. One can buy several contiguous(连续的) pieces at a time. Now given the list of prices of the land pieces, your job is to tell a customer in how many different ways that he/she can buy with a certain amount of money.
Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: N (≤104), the number of pieces of the land (hence the land pieces are numbered from 1 to N in order), and M (≤109), the amount of money that your customer has.
Then in the next line, N positive integers are given, where the i-th one is the price of the i-th piece of the land.
It is guaranteed that the total price of the land is no more than 109.
Output Specification:
For each test case, print the number of different ways that your customer can buy. Notice that the pieces must be contiguous.
Sample Input:
5 85
38 42 15 24 9
Sample Output:
11
Hint:
The 11 different ways are:
38
42
15
24
9
38 42
42 15
42 15 24
15 24
15 24 9
24 9
大概的题意是说,给定几块土地的价格,购买者想买几块挨着的土地或者是一块土地,问不超过给定购买者的钱数的情况下,有多少种购买方案
对于连续数组元素和的问题,可以用前缀和的方法解决
AC代码
#include<iostream>
using namespace std;
const int N=10010;
int a[N],sum[N];
int n,m;
int main()
{
cin>>n>>m;
for(int i=1;i<=n;++i)cin>>a[i];
for(int i=1;i<=n;++i)sum[i]=sum[i-1]+a[i];
int cnt=0;
for(int i=0;i<=n-1;++i)
for(int j=i+1;j<=n;++j)
if(sum[j]-sum[i]<=m)cnt++;
cout<<cnt<<endl;
return 0;
}