走迷宫
题目描述
给定一个 n×m 的二维整数数组,用来表示一个迷宫,数组中只包含 0 或 1,其中 0 表示可以走的路,1
表示不可通过的墙壁。
最初,有一个人位于左上角 (1,1)
处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角 (n,m)
处,至少需要移动多少次。
数据保证 (1,1)
处和 (n,m) 处的数字为 0
,且一定至少存在一条通路。
输入格式
第一行包含两个整数 n
和 m
。
接下来 n
行,每行包含 m 个整数(0 或 1
),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
数据范围
1≤n,m≤100
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8
这个题依然简单,我们只需要广搜就行
代码
#include <bits/stdc++.h>
using namespace std;
int a[105][105],n,m;
bool st[105][105];
queue<pair<int,int>> q;
int d[105][105];
int dx[4] = {-1, 0, 1, 0}, dy[4] = {0, 1, 0, -1};
int bfs(){
st[1][1] = 1;
q.push({1,1});
while(!q.empty()){
pair<int,int> t = q.front();
q.pop();
for(int i = 0; i < 4; i ++){
int x = t.first + dx[i];
int y = t.second + dy[i];
if(x < 1 || x > n || y < 1 || y > m || st[x][y] || a[x][y]) continue;
q.push({x,y});
st[x][y] = true;
d[x][y] = d[t.first][t.second] + 1;
}
}
return d[n][m];
}
int main(){
cin >> n >> m;
for(int i = 1; i <= n; i ++){
for(int j = 1; j <= m; j ++){
cin >> a[i][j];
}
}
cout << bfs();
return 0;
}
感觉缺了点什么,还是介绍下广搜吧
广搜全称叫广度优先搜索,或叫宽度优先搜索,简称BFS。人如其名,他不像深搜一路干到底,而是一层一层的搜索.
类似于
|
v