题目描述
医学部一共进行了 N场动物实验。
共有三种小动物可用来实验,分别是青蛙、老鼠和兔子。
每次实验都会选取其中一种动物来参与实验,选取数量若干。
现在请你统计一下医学部一共用了多少小动物,每种分别用了多少,每种动物使用数量占总量的百分比分别是多少。
样例
输入样例:
10
10 C
6 R
15 F
5 C
14 R
9 C
6 R
8 F
5 C
14 R
输出样例:
Total: 92 animals
Total coneys: 29
Total rats: 40
Total frogs: 23
Percentage of coneys: 31.52 %
Percentage of rats: 43.48 %
Percentage of frogs: 25.00 %
算法1
C++ 代码
#include<iostream>
using namespace std;
int main()
{
int n,c=0,r=0,f=0;
cin>>n;
for(int i=1;i<=n;i++){
int a;
char t;
cin>>a>>t;
if(t=='C') c+=a;
if(t=='R') r+=a;
if(t=='F') f+=a;
}
cout<<"Total: "<<c+r+f<<" animals"<<endl;
cout<<"Total coneys: "<<c<<endl;
cout<<"Total rats: "<<r<<endl;
cout<<"Total frogs: "<<f<<endl;
printf("Percentage of coneys: %.2lf %\n",(c*100.00)/(c+r+f));
printf("Percentage of rats: %.2lf %\n",(r*100.00)/(c+r+f));
printf("Percentage of frogs: %.2lf %\n",(f*100.00)/(c+r+f));
return 0;
}