题目描述
读取 $6$个整数 $A,B,C,D,E,F$,用来表示游戏的开始时间和结束时间。
其中 $A,B,C$分别表示开始时刻的小时数、分钟数、秒数,$D,E,F$分别表示结束时刻的小时数、分钟数、秒数。
请你计算游戏的持续时间。
游戏最短持续 $1$秒,最长持续 $24$小时。
输入格式
共一行,包含 $6$个整数 $A,B,C,D,E,F$。
输出格式
输出格式为 The game lasted X hour(s), Y minute(s), and Z second(s).
,表示游戏共持续了 $X$小时 $Y$分钟 $Z$秒。
数据范围
$0≤A,D≤23,\\0≤B,C,E,F≤59$
样例
输入样例
7 8 9 10 11 12
输出样例
The game lasted 3 hour(s), 3 minute(s), and 3 second(s).
$code$
#include<bits/stdc++.h>
using namespace std;
int a,b,c,d,e,f;
int main(){
cin>>a>>b>>c>>d>>e>>f;
if(a==d&&b==e&&c==f)
printf("The game lasted %d hour(s), %d minute(s), and %d second(s).",24,0,0);
else{
if (c>f) e--,f+=60;
if (b>e) d--,e+=60;
if (a>d) d+=24;
printf("The game lasted %d hour(s), %d minute(s), and %d second(s).",(d-a),(e-b),(f-c));
}
return 0;
}