题目描述
给定你三个英语单词,这些词将根据下表从左到右定义一个动物。
请你确定并输出这个动物的名称。
输入格式
根据上表,输入包含三个单词,每行一个,用以识别动物,单词由小写字母构成。
输出格式
输出识别出的动物的名称。
输入样例:
vertebrate
mammal
omnivore
输出样例:
human
C++ 代码
#include<bits/stdc++.h>
using namespace std;
int main(){
string s[4];
cin>>s[1];
cin>>s[2];
cin>>s[3];
if(s[1]=="vertebrate")
{
if(s[2]=="mammal")
{
if(s[3]=="omnivore")cout<<"human";
else cout<<"cow";
}
if(s[2]=="bird")
{
if(s[3]=="omnivore")cout<<"pigeon";
if(s[3]=="carnivore")cout<<"eagle";
}
}
if(s[1]=="invertebrate")
{
if(s[2]=="insect")
{
if(s[3]=="herbivore")cout<<"caterpillar";
else cout<<"flea";
}
if(s[2]=="annelid")
{
if(s[3]=="omnivore")cout<<"worm";
else cout<<"leech";
}
}
return 0;
}
这道题我用的纯暴力,蒟蒻代码望理解awa