题目描述
实现一个队列,队列初始为空,支持四种操作:
(1) “push x” – 向队尾插入一个数x;
(2) “pop” – 从队头弹出一个数;
(3) “empty” – 判断队列是否为空;
(4) “query” – 查询队头元素。
现在要对队列进行M个操作,其中的每个操作3和操作4都要输出相应的结果。
输入格式
第一行包含整数M,表示操作次数。
接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”query”中的一种
样例
输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4
模拟就完事了
上代码
#include<iostream>
#include<cstring>
using namespace std;
int n,k,q=1,h=0,a[1000001];
string l;
void push(int x){
h++;
a[h]=x;
}
void pop(){
q++;
}
bool empty(){
if(q>h) return true;
return false;
}
int top(){
return a[q];
}
int main(){
ios::sync_with_stdio(false);
cin>>n;
while(n--){
cin>>l;
if(l=="push"){
cin>>k;
push(k);
}
else if(l=="empty"){
if(!empty()) cout<<"NO"<<endl;
else cout<<"YES"<<endl;
}
else if(l=="pop") pop();
else cout<<top()<<endl;
}
return 0;
}