题目描述
维护一个集合,支持如下几种操作:
“I x”,插入一个数x;
“Q x”,询问数x是否在集合中出现过;
现在要进行N次操作,对于每个询问操作输出对应的结果。
输入格式
第一行包含整数N,表示操作数量。
接下来N行,每行包含一个操作指令,操作指令为”I x”,”Q x”中的一种。
输出格式
对于每个询问指令“Q x”,输出一个询问结果,如果x在集合中出现过,则输出“Yes”,否则输出“No”。
每个结果占一行。
数据范围
1≤N≤105
−109≤x≤109
样例
输入样例:
5
I 1
I 2
I 3
Q 2
Q 5
输出样例:
Yes
No
算法1
C++ 代码
#include<iostream>
#include<cstring>
using namespace std;
int n;
const int N=200003,null=0x3f3f3f3f;
int p[N];
int find(int x){
int t = (x % N + N) % N;
while (p[t] != null && p[t] != x)
{
t ++ ;
if (t == N) t = 0;
}
return t;
}
int main(){
cin>>n;
memset(p,0x3f,sizeof p);
while(n--){
string op;
int x;
cin>>op>>x;
if(op=="I") p[find(x)]=x;
else (p[find(x)]!=null)?(puts("Yes")):(puts("No"));
}
return 0;
}
算法2
C++ 代码
#include<iostream>
#include<unordered_set>
using namespace std;
unordered_set<int> s;
int main(){
int n;
cin>>n;
while(n--){
string op;int x;
cin>>op>>x;
if(op=="I")s.insert(x);
else {
if(s.count(x)!=0)puts("Yes");
else puts("No");
}
}
return 0;
}
#include<iostream>
#include<unordered_map>
using namespace std;
unordered_map<int,bool> s;
int main(){
int n;
cin>>n;
for(int i=0;i<n;i++){
string op;int x;
cin>>op>>x;
if(op=="I")s[x]=1;
else {
s[x]?puts("Yes"):puts("No");
}
}
return 0;
}