spfa求最短路
给定一个n个点m条边的有向图,图中可能存在重边和自环, 边权可能为负数。
请你求出1号点到n号点的最短距离,如果无法从1号点走到n号点,则输出impossible。
数据保证不存在负权回路。
输入格式
第一行包含整数n和m。
接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。
输出格式
输出一个整数,表示1号点到n号点的最短距离。
如果路径不存在,则输出”impossible”。
数据范围
1≤n,m≤10^5,
图中涉及边长绝对值均不超过10000。
输入样例
3 3
1 2 5
2 3 -3
1 3 4
输出样例
2
代码
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stdio.h>
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int N = 100010;
int n, m;
int e[N], ne[N], h[N], w[N], idx;//邻接表
int dist[N];//距离
bool st[N];//判断是否已经加入队列
void add(int a, int b, int c)//构造邻接表
{
e[idx] = b;
w[idx] = c;//权重
ne[idx] = h[a];
h[a] = idx++;
}
int spfa()
{
memset(dist, 0x3f, sizeof dist);
dist[1] = 0;
queue<int>q;//记录一下当前发生过更新的点
q.push(1);
st[1] = true;
while (q.size())//队列不空
{
int t = q.front();//取出队头
q.pop();//删除队头
st[t] = false;
for (int i = h[t]; i !=-1; i=ne[i])
{
int j = e[i];
if (dist[j] > dist[t] + w[i])
{
dist[j] = dist[t] + w[i];
if (!st[j])//已经加入的点不需要再次添加
{
q.push(j);//把更新的点加入队列
st[j] = true;
}
}
}
}
if (dist[n] == 0x3f3f3f3f)//仍是最大值即不存在最短路
return -1;
else
return dist[n];
}
int main()
{
cin >> n >> m;
//初始化
memset(h, -1, sizeof h);
while (m--)
{
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
add(a, b, c);
}
if (spfa() == -1)
printf("impossible");
else
printf("%d", spfa());
return 0;
}
spfa判断负环
给定一个n个点m条边的有向图,图中可能存在重边和自环, 边权可能为负数。
请你判断图中是否存在负权回路。
输入格式
第一行包含整数n和m。
接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。
输出格式
如果图中存在负权回路,则输出“Yes”,否则输出“No”。
数据范围
1≤n≤2000,
1≤m≤10000,
图中涉及边长绝对值均不超过10000。
输入样例
3 3
1 2 -1
2 3 4
3 1 -4
输出样例
Yes
代码
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stdio.h>
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int N = 100010;
int n, m;
int e[N], ne[N], h[N], w[N], idx;//邻接表
int dist[N];//距离
int cnt[N];//边数
bool st[N];//判断是否已经加入队列
void add(int a, int b, int c)//构造邻接表
{
e[idx] = b;
w[idx] = c;//权重
ne[idx] = h[a];
h[a] = idx++;
}
int spfa()
{
queue<int>q;//记录一下当前发生过更新的点
//判断是否有负环,需要将所有的点加入队列,更新周围的点
//处理不连通问题
for (int i = 1; i <= n; i++)
{
q.push(i);
st[i] = true;
}
while (q.size())//队列不空
{
int t = q.front();//取出队头
q.pop();//删除队头
st[t] = false;
for (int i = h[t]; i !=-1; i=ne[i])
{
int j = e[i];
if (dist[j] > dist[t] + w[i])
{
dist[j] = dist[t] + w[i];
cnt[j] = cnt[t] + 1;//边数加一
if (cnt[j] >= n)
return true;
if (!st[j])//已经加入的点不需要再次添加
{
q.push(j);//把更新的点加入队列
st[j] = true;
}
}
}
}
return false;
}
int main()
{
cin >> n >> m;
//初始化
memset(h, -1, sizeof h);
while (m--)
{
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
add(a, b, c);
}
if (spfa())
printf("Yes");
else
printf("No");
return 0;
}