1189:Pell数列
时间限制: 1000 ms 内存限制: 65536 KB
提交数: 16481 通过数: 8261
【题目描述】
Pell数列a1,a2,a3,…的定义是这样的,a1=1,a2=2,…,an=2an−1+an−2(n>2)。
给出一个正整数k,要求Pell数列的第k项模上32767是多少。
【输入】
第1行是测试数据的组数n,后面跟着n行输入。每组测试数据占1行,包括一个正整数k (1≤k<1000000)。
【输出】
n行,每行输出对应一个输入。输出应是一个非负整数。
【输入样例】
2
1
8
【输出样例】
1
408
//递推
#include <iostream>
#include <cstdio>
using namespace std;
const int N = 1000001;
const int mod = 32767;
int f[N], n, x;
int main(){
scanf("%d",&n);
f[1] = 1; f[2] = 2;
for(int i = 3; i <= 1000000; i++) f[i] = (2 * f[i-1] + f[i-2]) % mod;
while(n--){
scanf("%d",&x);
printf("%d\n",f[x]);
}
return 0;
}
//记忆化递归#include <iostream>
#include <cstdio>
using namespace std;
const int N = 1000001;
const int mod = 32767;
int f[N], n, x;
int pell(int x){
if(!f[x]) return f[x] = (2*pell(x-1) + pell(x-2)) % mod;
return f[x];
}
int main(){
scanf("%d",&n);
f[1] = 1; f[2] = 2;
while(n--){
scanf("%d",&x);
printf("%d\n",pell(x));
}
return 0;
}