原题链接:日期问题
题目描述
小明正在整理一批历史文献。这些历史文献中出现了很多日期。
小明知道这些日期都在1960年1月1日至2059年12月31日。
令小明头疼的是,这些日期采用的格式非常不统一,有采用年/月/日的,有采用月/日/年的,还有采用日/月/年的。
更加麻烦的是,年份也都省略了前两位,使得文献上的一个日期,存在很多可能的日期与其对应。
比如02/03/04,可能是2002年03月04日、2004年02月03日或2004年03月02日。
给出一个文献上的日期,你能帮助小明判断有哪些可能的日期对其对应吗?
输入格式
一个日期,格式是”AA/BB/CC”。
即每个’/’隔开的部分由两个 0-9 之间的数字(不一定相同)组成。
输出格式
输出若干个不相同的日期,每个日期一行,格式是”yyyy-MM-dd”。
多个日期按从早到晚排列。
数据范围
$0≤A,B,C≤9$
输入样例1:
02/03/04
输出样例1:
2002-03-04
2004-02-03
2004-03-02
思路
我自己写的时候直接写了一个大模拟,花了我老长时间。
这题实际上有更简单的写法
- 枚举从19600101 ~ 20591231
- 然后判断日期是否合法
- 在日期合法的前提下,判断是否满足 年/月/日,月/日/年,日/月/年
C++ 代码
#include <cstdio>
#include <iostream>
using namespace std;
const int days[] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
bool check_valid(int year, int month, int day) {
if(month <= 0 || month > 12) return false;
if(day == 0) return false;
if(month != 2) {
if(day > days[month]) return false;
}else {
int leap = year % 100 && year % 4 == 0 || year % 400 == 0;
if(day > 28 + leap) return false;
}
return true;
}
int main()
{
int a, b, c;
scanf("%d/%d/%d",&a,&b,&c);
for(int i = 19600101;i <= 20591231;i ++) {
int year = i / 10000, month = i % 10000 / 100, day = i % 100;
if(check_valid(year,month,day)) {
if(year % 100 == a && month == b && day == c || // 年/月/日
month == a && day == b && year % 100 == c || // 月/日/年
day == a && month == b && year % 100 == c) // 日/月/年
printf("%d-%02d-%02d\n",year,month,day);
}
}
return 0;
}
我的代码
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
const int N = 1000010;
struct RES {
int y;
int m;
int d;
bool operator < (const RES &r) const {
if(y == r.y && m == r.m) return d < r.d;
else if(y == r.y) return m < r.m;
return y < r.y;
}
bool operator != (const RES &r) const {
if(y == r.y && m == r.m && d == r.d) return false;
return true;
}
}res[N],temp[N];
int cnt;
int a, b, c; // 0 - 99 (a,b,c) (c,a,b) (c,b,a)
const int days[] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
bool valid(int y,int m,int d) {
if(y < 1960 || y > 2059) return false;
if(m <= 0 || m > 12 || d <= 0) return false;
if(m != 2 && d > days[m]) return false;
if(m == 2) {
int leap = y % 100 && y % 4 == 0 || y % 400 == 0;
if(d > days[m] + leap) return false;
}
return true;
}
void get(int x) {
// (a,b,c) (b,c,a) (c,b,a)
int y1 = x * 100 + a;
int y2 = x * 100 + c;
int y3 = x * 100 + c;
if(valid(y1,b,c)) res[cnt ++] = {y1,b,c};
if(valid(y2,a,b)) res[cnt ++] = {y2,a,b};
if(valid(y3,b,a)) res[cnt ++] = {y3,b,a};
}
void unionstu() {
int n = cnt;
cnt = 0;
for(int i = 0;i < n;i ++){
if(!i || res[i] != res[i - 1]){
res[cnt ++] = res[i];
}
}
}
int main()
{
scanf("%d/%d/%d",&a,&b,&c);
for(int i = 10;i < 100;i ++) {
get(i);
}
sort(res,res + cnt);
// for(int i = 0;i < cnt;i ++) printf("%04d-%02d-%02d\n",res[i].y,res[i].m,res[i].d);
// cout << endl;
unionstu();
for(int i = 0;i < cnt;i ++) printf("%04d-%02d-%02d\n",res[i].y,res[i].m,res[i].d);
return 0;
}
y总代码
#include <cstdio>
#include <iostream>
using namespace std;
const int days[] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
bool check_valid(int year, int month, int day) {
if(month <= 0 || month > 12) return false;
if(day == 0) return false;
if(month != 2) {
if(day > days[month]) return false;
}else {
int leap = year % 100 && year % 4 == 0 || year % 400 == 0;
if(day > 28 + leap) return false;
}
return true;
}
int main()
{
int a, b, c;
scanf("%d/%d/%d",&a,&b,&c);
for(int i = 19600101;i <= 20591231;i ++) {
int year = i / 10000, month = i % 10000 / 100, day = i % 100;
if(check_valid(year,month,day)) {
if(year % 100 == a && month == b && day == c || // 年/月/日
month == a && day == b && year % 100 == c || // 月/日/年
day == a && month == b && year % 100 == c) // 日/月/年
printf("%d-%02d-%02d\n",year,month,day);
}
}
return 0;
}