题目描述
实现一个队列,队列初始为空,支持四种操作:
push x
– 向队尾插入一个数$x$;pop
– 从队头弹出一个数;empty
– 判断队列是否为空;query
– 查询队头元素。
现在要对队列进行 $M$ 个操作,其中的每个操作 $3$ 和操作 $4$ 都要输出相应的结果。
输入格式
第一行包含整数 $M$,表示操作次数。
接下来 $M$ 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示队头元素的值。
数据范围
$1≤M≤100000$
$1≤x≤10^9$
所有操作保证合法。
输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4
代码&思路
做法一
#include<iostream>
using namespace std;
const int N = 100010;
int q[N],hh,tt;//
int main()
{
int n;
cin>>n;
while(n--)
{
int x;
string op;
cin>>op;
if(op=="push")
{
cin>>x;
q[tt++]=x;//
}
if(op=="pop")
{
hh++;
}
if(op=="empty")
{
if(hh>=tt) cout<<"YES"<<endl;//
else cout<<"NO"<<endl;
}
if(op=="query")
{
cout<<q[hh]<<endl;
}
}
return 0;
}
做法二
#include<iostream>
using namespace std;
const int N = 100010;
int q[N],hh,tt=-1;//
int main()
{
int n;
cin>>n;
while(n--)
{
int x;
string op;
cin>>op;
if(op=="push")
{
cin>>x;
q[++tt]=x;//
}
if(op=="pop")
{
hh++;
}
if(op=="empty")
{
if(hh>tt) cout<<"YES"<<endl;//
else cout<<"NO"<<endl;
}
if(op=="query")
{
cout<<q[hh]<<endl;
}
}
return 0;
}
上面两种做法的区别我用//
标了一下
主要的区别就是:
第一种是tt从0开始的(全局变量默认为0),而第二种从-1开始
而这一小小的区别就需要我们去注意许多细节
当tt
从-1
开始的时候,我们在进行插入的时候要写成q[++tt]
,反之写成q[tt++]
我个人认为这是因为数组的下标不能为-1
所以要先进行++
另外
hh
都是从0
开始的
所以当tt
从0
开始的时候,tt
与hh
一开始是相等的,而一开始队列为空,这就说明当hh==tt
的时候,队列为空
而tt
从-1
开始的时候,如果tt
等于了0,tt
加了一,就说明已经插入了一个元素,此时hh==tt
的时候,队列不为空
总结一下:
tt可以从0开始也可以从-1开始,看个人的习惯
当tt从0开始的时候,hh==tt队列为空
当tt从-1开始的时候,要先++,hh==tt队列不为空