Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.
All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210
题目简述 :
本题要求求出 1号点到其他点 的最短路以及 其他点到1号 的最短路之和。
做法:
需要两遍dijkstra。
第一遍,通过正向建边,得到第一遍1号点到其他点。
第二遍,通过反向建边,得到每个点到1号点的最短距离。
在两遍dijkstra的时候,个人的做法是将他们尽量分开不耦合。
C++
#include <cstring>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include <queue>
using namespace std ;
typedef pair<int, int > PII ;
#define x first
#define y second
const int N = 1e6+10 , M = N;
int d[N] ;
int st[N] ;
int n , m;
int h[N] , ne[M] , e[M] , idx , w[M];
int h_r[N] , ne_r[M] , e_r[M] , idx_r , w_r[M];
void add(int a, int b ,int c)
{
w[idx] = c , e[idx] = b , ne[idx] = h[a] , h[a] = idx ++ ;
}
void add_r(int a, int b ,int c)
{
w_r[idx_r] = c , e_r[idx_r] = b , ne_r[idx_r] = h_r[a] , h_r[a] = idx_r ++ ;
}
void init()
{
memset(h,-1,sizeof h) ;
memset(h_r,-1,sizeof h_r) ;
memset(e,0,sizeof e) ;
memset(e_r,0,sizeof e_r) ;
memset(w,0,sizeof w) ;
memset(w_r,0,sizeof w_r) ;
memset(ne,0,sizeof ne) ;
memset(ne_r,0,sizeof ne_r) ;
memset(st,0,sizeof st) ;
memset(d,0x3f ,sizeof d) ;
idx =idx_r= 0 ;
}
void dijkstra(int u )
{
priority_queue<PII, vector<PII> ,greater<PII> > q ;
d[u] = 0 ;
q.push({d[u] , u}) ;
while(q.size())
{
int dist = q.top().x ;
int ver = q.top().y ;
q.pop() ;
if(st[ver]) continue ;
st[ver] = 1 ;
for(int i= h[ver] ; ~i ; i = ne[i])
{
int j = e[i] ;
if(d[j] > d[ver] + w[i])
{
d[j] = d[ver] + w[i] ;
q.push({d[j],j}) ;
}
}
}
}
void dijkstra_r(int u )
{
priority_queue<PII, vector<PII> ,greater<PII> > q ;
d[u] = 0 ;
q.push({d[u] , u}) ;
while(q.size())
{
int dist = q.top().x ;
int ver = q.top().y ;
q.pop() ;
if(st[ver]) continue ;
st[ver] = 1 ;
for(int i= h_r[ver] ; ~i ; i = ne_r[i])
{
int j = e_r[i] ;
if(d[j] > d[ver] + w_r[i])
{
d[j] = d[ver] + w_r[i] ;
q.push({d[j],j}) ;
}
}
}
}
int main()
{
int T ;
scanf("%d" ,&T) ;
while(T--)
{
init() ;
scanf("%d%d",&n,&m) ;
while(m--)
{
int a , b , c ;
scanf("%d%d%d",&a,&b,&c) ;
add(a,b,c) ;
add_r(b,a,c) ;
}
int res = 0 ;
dijkstra(1) ;
for(int i = 1 ; i <= n ; i ++ )
{
res += d[i] ;
}
memset(d, 0x3f, sizeof d ) ;
memset(st, 0, sizeof st) ;
dijkstra_r(1) ;
for(int i = 2 ; i <= n ; i ++ )
{
res += d[i] ;
}
printf("%d\n" , res) ;
}
return 0 ;
}