题目描述
输入一个长度为n的整数数列,从小到大输出前m小的数。
输入格式
第一行包含整数n和m。
第二行包含n个整数,表示整数数列。
输出格式
共一行,包含m个整数,表示整数数列中前m小的数。
数据范围
1≤m≤n≤105
,
1≤数列中元素≤109
样例
输入样例:
5 3
4 5 1 3 2
输出样例:
1 2 3
算法1
(STL优先队列)
C++ 代码
#include <iostream>
#include <queue>
using namespace std;
int n,m,a;
priority_queue<int, vector<int>, greater<int> > h; //这样出来的就是小根堆啦
int main(){
scanf("%d%d",&n,&m);
while(n--) scanf("%d",&a), h.push(a);
while(m--) printf("%d ",h.top()) , h.pop();
return 0;
}
#include<bits/stdc++.h> //万能头文件,但是会稍影响速度啦,据说POJ不能AC
#include <iostream>
#include <queue>
using namespace std;
int n,m,a;
priority_queue<int> h;
int main(){
scanf("%d%d",&n,&m);
while(n--) scanf("%d",&a), h.push(-a);
while(m--) printf("%d ",-h.top()) , h.pop();
return 0;
}
算法2
(手写实现)
比较了三种不同的方法,速度基本上差不多
C++ 代码
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 1000010;
int h[N], size;
void down(int u){
int t = u;
if (u * 2 <= size && h[u * 2] < h[t]) t = u * 2;
if (u * 2 + 1 <= size && h[u * 2 + 1] < h[t]) t = u * 2 + 1;
if (u != t) swap(h[t], h[u]), down(t);
}
int main()
{
int n, m;
cin >> n >> m;
for (int i = 1; i <= n; i ++) cin >> h[i];
size = n;
for (int i = n / 2; i; i --) down(i);
while (m --){
cout << h[1] << " ";
h[1] = h[size];
size --;
down(1);
}
return 0;
}