有向图的拓扑排序
不要忘记初始化头节点终止条件
给定一个n个点m条边的有向图,图中可能存在重边和自环。
请输出任意一个该有向图的拓扑序列,如果拓扑序列不存在,则输出-1。
若一个由图中所有点构成的序列A满足:对于图中的每条边(x, y),x在A中都出现在y之前,则称A是该图的一个拓扑序列。
输入格式
第一行包含两个整数n和m
接下来m行,每行包含两个整数x和y,表示点x和点y之间存在一条有向边(x, y)。
输出格式
共一行,如果存在拓扑序列,则输出拓扑序列。
否则输出-1。
数据范围
$1≤n,m≤10^5$
输入样例:
3 3
1 2
2 3
1 3
输出样例:
1 2 3
代码:
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 1e5+10;
int n, m;
int h[N], e[N], ne[N], idx;
int q[N], d[N];
//d:当前点入度
void add(int a, int b) {
e[idx] = b, ne[idx] = h[a], h[a] = idx++;
}
bool topsort() {
int hh = 0, tt = -1;
//d[i] 存储点i的入度
for(int i = 1; i <= n; i++)
if(!d[i])
q[++tt] = i;
while(hh <= tt) {
int t = q[hh++];
for(int i = h[t]; i != -1; i = ne[i]) {
int j = e[i];
if(--d[j] == 0)
q[++tt] = j;
}
}
return tt == n - 1;
}
int main() {
cin >> n >> m;
memset(h, -1, sizeof h);
//忘记初始化导致topsort中for循环无法终止
for(int i = 0; i < m; i++) {
int a, b;
cin >> a >> b;
add(a, b);
d[b]++;
}
if(topsort()) {
for(int i = 0; i < n; i++) cout << q[i] << ' ';
puts("");
} else puts("-1");
return 0;
}
请问tt为什么要从-1开始
习惯用一个特殊值代替了