题目描述
输入两个整数,求这两个整数的和是多少。
样例
样例输入:
3 4
样例输出:
7
算法1
(正常算法) $O(1)$
读入$a$和$b$,输出$a+b$。
时间复杂度 $O(1)$
参考文献 无
C++ 代码
#include<bits/stdc++.h>
using namespace std;
int a,b;
int main(){
cin.tie(0);
ios::sync_with_stdio(false);
cin>>a>>b;
cout<<a+b<<endl;
return 0;
}
算法2
(try and catch) $O(1)$
使用try-catch
语句,搞怪做法
时间复杂度 $O(1)$
参考文献 无
C++ 代码
#include<bits/stdc++.h>
using namespace std;
int sum;
int main(){
cin.tie(0);
ios::sync_with_stdio(false);
try{
try{
try{
int a;
cin>>a;
throw a;
}
catch(int y){
sum+=y;
}
int a;
cin>>a;
throw a;
}
catch(int x){
sum+=x;
}
throw sum;
}
catch(int z){
cout<<z<<endl;
}
return 0;
}