题目描述
农民John有很多牛,他想交易其中一头被Don称为The Knight的牛。
这头牛有一个独一无二的超能力,在农场里像Knight一样地跳(就是我们熟悉的象棋中马的走法)。
虽然这头神奇的牛不能跳到树上和石头上,但是它可以在牧场上随意跳,我们把牧场用一个x,y的坐标图来表示。
这头神奇的牛像其它牛一样喜欢吃草,给你一张地图,上面标注了The Knight的开始位置,树、灌木、石头以及其它障碍的位置,除此之外还有一捆草。
现在你的任务是,确定The Knight要想吃到草,至少需要跳多少次。
The Knight的位置用’K’来标记,障碍的位置用’*’来标记,草的位置用’H’来标记。
这里有一个地图的例子:
11 | . . . . . . . . . .
10 | . . . . * . . . . .
9 | . . . . . . . . . .
8 | . . . * . * . . . .
7 | . . . . . . . * . .
6 | . . * . . * . . . H
5 | * . . . . . . . . .
4 | . . . * . . . * . .
3 | . K . . . . . . . .
2 | . . . * . . . . . *
1 | . . * . . . . * . .
0 ----------------------
1
0 1 2 3 4 5 6 7 8 9 0
The Knight 可以按照下图中的A,B,C,D…这条路径用5次跳到草的地方(有可能其它路线的长度也是5):
11 | . . . . . . . . . .
10 | . . . . * . . . . .
9 | . . . . . . . . . .
8 | . . . * . * . . . .
7 | . . . . . . . * . .
6 | . . * . . * . . . F<
5 | * . B . . . . . . .
4 | . . . * C . . * E .
3 | .>A . . . . D . . .
2 | . . . * . . . . . *
1 | . . * . . . . * . .
0 ----------------------
1
0 1 2 3 4 5 6 7 8 9 0
输入格式
第1行: 两个数,表示农场的列数C(C<=150)和行数R(R<=150)。
第2..R+1行: 每行一个由C个字符组成的字符串,共同描绘出牧场地图。
输出格式
一个整数,表示跳跃的最小次数。
样例
输入样例:
10 11
..........
....*.....
..........
...*.*....
.......*..
..*..*...H
*.........
...*...*..
.K........
...*.....*
..*....*..
输出样例:
5
广度优先搜索
一般来说走迷宫,最少步数这种题目,都是广度优先搜索.记住读入上面的有梗,然后修改一下一般走路方式就好了.
C++ 代码
#include <bits/stdc++.h>
using namespace std;
#define pii pair<int,int>
#define mk(a,b) make_pair(a,b)
#define fir(i,a,b) for(int i=a;i<=b;i++)
const int dx[8]= {1,2,2, 1,-1,-2,-2,-1};//中国象棋马的正确走路姿势
const int dy[8]= {2,1,-1,-2,-2,-1,1,2};//一头不遵循国际象棋,而遵循中国象棋的外国牛
char s[160][160];
int n,m,dis[160][160];
pii st,ed;
queue<pii> q;
bool check(int x,int y)
{
return x>=1 && x<=n && y>=1 && y<=m && s[x][y]!='*' && dis[x][y]==-1;//在范围内;且不是障碍物;第一次被访问
}
void st_ed(void)//找起点和终点
{
fir(i,1,n)
fir(j,1,m)
{
if (s[i][j]=='K')
{
st.first=i;
st.second=j;
}
if (s[i][j]=='H')
{
ed.first=i;
ed.second=j;
}
}
}
int bfs(void)
{
memset(dis,-1,sizeof(dis));
q.push(mk(st.first,st.second));//压入起点
dis[st.first][st.second]=0;
while(q.size())
{
pii now=q.front();
q.pop();
fir(i,0,7)
{
int x=now.first+dx[i],y=now.second+dy[i];//拓展
if (check(x,y))//满足条件
{
dis[x][y]=dis[now.first][now.second]+1;
q.push(mk(x,y));
if (x==ed.first && y==ed.second)//到达终点了
return dis[x][y];
}
}
}
return -1;//然而并没有无解情况
}
int main()
{
//freopen("stdin.in","r",stdin);
scanf("%d%d\n",&m,&n);//读入要小心,不然就会Game Over,你就会发现你从第三组后面的数据死活无法AC.
fir(i,1,n)
scanf("%s",s[i]+1);//读入从字符1开始
st_ed();
cout<<bfs();
return 0;
}
#include[HTML_REMOVED]
#include[HTML_REMOVED]
#include[HTML_REMOVED]
using namespace std;
#define x first
#define y second
typedef pair[HTML_REMOVED] PII;
const int N = 200;
int C,R,cnt;
char g[N][N];
int dist[N][N];
PII q[N * N];
int dx[8] = {-2,-1,1,2,2,1,-1,-2},dy[8] = {1,2,2,1,-1,-2,-2,-1};
int bfs(PII st,PII ed)
{
int hh = 0,tt = 0;
}
int main()
{
cin >> C >> R;
for(int i = 0;i < R;i ++) cin>>g[i];
}
这个代码哪里错了,佬能帮我看看么
更好的阅读体验网址404qwq
秦佬前面这一堆定义很骚~
emm,还好吧…